VirusHC User Manual - Lower Patch / Multi Bank content view

Access Virus Editor Using The Librarian (EN) Chapter 5

User Manuals Knowledge Level

Everything you need to know about our plug-in install, setup steps, configuration and usage of various features

for Access Virus Editor & Librarian plug-in by Mystery Islands Music

v3.0.0 - 2021-October-26

LIBRARIAN FUNCTIONS

With our built-in Patch / Multi Librarian, the user can manipulate banks as they like.  Drag’n’drop patches / multis from one bank to another, rename patches / multis and store the desired bank to the synthesizer’s memory or pull banks from memory to librarian.

This is quite an extensive guide, so we want to walk you through every step one by one while trying to write everything down in a most-common way. So, get some coffee or tea and let’s begin!

p.s. Current Virus multi data does not contain data from individual parts. We are going to include this with our own “performance” data. Check our roadmap!

TIP #1: Always make sure that your multi or patch banks are not named such as: “this_is_the_ultimate_dance_and_trance_leads_mashup_bank_volume_2_of_5.mid”

I can tell you right now, that the plug-in and librarian is not going to like it and might even crash. Make sure to keep your patch names clean and simple. If you can not see the bank name extension in the librarian menu, revise the bank name to be less than 32 characters.

TIP #2: You can always create a set of sub folders in your Patches folder to organize your Banks better. See image below how I’ve organized my banks to keep them in tidy order. This way the Bank name does not exceed the suggested length.

VirusHC User Manual - Patch / Multi data location

Virus Editor User Manual – Patch / Multi data location

Select Program with Double Click

Double clicking any item in the librarian program view, will send the slot data to the hardware temp memory. If you have Part 1 selected in the plug-in user interface and you double click slot 12 while in Patch mode, then slot 12 data will be sent to Part 1 in your Virus!

This will also update the plug-in interface, so it is in sync with the data on your Virus!

Select Program using Arrow keys from keyboard

You can also use Arrow keys from your computer keyboard to browse through different programs in the librarian view. Clicking arrow up while slot 1 is chosen, will choose slot 128 as a next slot. Using left arrow key while in slot 128, will choose slot 112 next and send it to hardware.

Note #1: this only works when you mouse cursor is on top of the upper or lower program view area.

Note #2: if you have chosen to browse in lower program view, then program from lower program view will be sent to hardware. Same applies to upper program view too, so if you are browsing programs in that view, then the corresponding data will be sent to hardware.

Note #3: This will also update the plug-in user interface with the program values.

Different Sections in Librarian User Interface

Left Patch / Multi Program View

[1] This is the main “edit” area of your active bank. What ever you edit in the upper bank view, can be stored later on. You can rename individual Patches / Multis, request data from hardware to the bank slots, Initialize Patches / Multis as you go and quickly get data from the plug-in user interface to the selected slot or store single data or whole bank to the hardware.

More details about the BANK EDIT functions and Right Click Menu functions below in this document.

VirusHC User Manual - Upper Patch / Multi Bank content view

Virus Editor User Manual – Upper Patch / Multi Bank content view

NOTE #1 Once you start to manipulate the bank, DISCARD [1] button will appear between the bank names indicating that you’ve started your editing work.

NOTE #2 Once the Discard button appears, you can not change to different Librarian Mode [2] nor you can’t change to different bank with upper Patch / Multi bank menu [3] until changes are saved or discarded.

NOTE #3 You can still use the lower Patch / Multi bank menu [4] to browse other banks while the main edit area is locked! See details below.

VirusHC User Manual - Lower Menu is operational even when edits has been made

Virus Editor User Manual – Lower Menu is operational even when edits has been made

Lower Patch / Multi Program View

[1] This is our “helping tool” bank view which allows you to view other bank contents while the main edit view is locked due to ongoing edits. You can copy selected slot Patch / Multi to clipboard and paste it on the main edit view. You can also drag’n’drop data from any slot to main edit view.

Learn more details about Copy & Paste and Drag’n’drop further below the document.

VirusHC User Manual - Lower Patch / Multi Bank content view

Virus Editor User Manual – Lower Patch / Multi Bank content view

Previous & Next Bank buttons

You can quickly navigate to previous or next bank in the list by clicking the PREVIOUS [1] or NEXT [2] bank button.

VirusHC User Manual - Next / Previous Bank Select

Virus Editor User Manual – Next / Previous Bank Select

Note #1 that both “views” have their own Previous / Next buttons.

Bank Select Menu

Clicking the Bank Name [1 / 2] opens up the popup menu which displays all the current Patch / Multi bank files based on your Librarian Mode selection. See details below the image.

VirusHC User Manual - Dual Bank Select Menus

Virus Editor User Manual – Dual Bank Select Menus

NOTE #1 Bank Name [1] menu becomes inactive if bank has edits in it. Save changes or Discard edits in order to browse other banks in this area.

Librarian View / Operation Mode

LIBRARIAN VIEW [1] button allows users to toggle between Multi / Patch files in librarian view. Multis contain general info about all of the 16 parts. Like noted in the first section, multis does not contain any patch data. That is how Access made the multi format. We will change that in future to contain patches from all 16 as well. You can also toggle the mode from the main user interface PATCH / MULTI [2] button to toggle between the modes.

VirusHC User Manual - Librarian Operation Mode

Virus Editor User Manual – Librarian Operation Mode

Search

Search can the toggled on by clicking the Magnifying Glass [1]Name Field [2] will popup allowing you to to enter your search criteria. Search results will appear in the Lower Program View [3] if there are any.

VirusHC User Manual - Search Function

Virus Editor User Manual – Search Function

NOTE #1 Search works based on character size. If the search term is less than 3 characters, search won’t give any results.

Request Interval

Set a desired REQUEST INTERVAL [1] for your request and write commands. Default is set to 300ms, but in some cases it might cause time out messages. If that is the case, then increase the Request Interval until requests succeed.

VirusHC User Manual - Request Interval

Virus Editor User Manual – Request Interval

Note #1 When making requests to librarian, try not to interfere the MIDI flow by any means. This might cause unexpected results and could potentially freeze the plug-in until its forced to restart. Once the request process is ongoing, sit back for a few minutes 😎

Save Data To Slot

With SAVE DATA TO SLOT [1] you can quickly get data from the plug-in user interface to the librarian. Data will be requested from the selected part [2] and data will be put to an active slot [3] on main edit window. If lower program display is chosen, this function will not be available. Once the data is in the chosen librarian slot, you can then save the bank, rename the patch / multi or discard your changes.

VirusHC User Manual - Save Data to Slot

Virus Editor User Manual – Save Data to Slot

Sync Data From HW

SYNC DATA FROM HW [1] does what it says. This will get all of the temp multi, parts (1-16) and system data from the synthesizer to the plug-in user interface. Once you’ve set your MIDI in and MIDI out you are better off to start with Sync Data from HW before you start to work with the interface in the first place.

The reason is quite simple; we need to get the current hardware status to the plug-in user interface to address control changes and MIDI messages to the right layers etc.

VirusHC User Manual - Sync Data from Virus

Virus Editor User Manual – Sync Data from Virus

Push Data To HW

PUSH DATA TO HW [1] works like Total Recall but in manual mode. This will send the entire Multi data, all 16 parts patch data and the System settings to hardware.

This is useful when you open your project containing the plug-in but for some reason you’ve lost the MIDI interface along the way or if you open your project in another studio without the MIDI interface attached when you saved your work. You can choose different MIDI in and MIDI out and click Push Data to HW and you’ll get the sound in the Virus, regardless of the place you are at.

VirusHC User Manual - Push Data to Virus

Virus Editor User Manual – Push Data to Virus

Abort Process

ABORT PROCESS [1] button will briefly appear when you make requests from hardware to plug-in user interface or when you send Patches / Multis to the hardware. If something in the hardware settings isn’t right and / or the process takes too long, you can Abort the process and start from beginning manually.

VirusHC User Manual - Abort Request / Write Process

Virus Editor User Manual – Abort Request / Write Process

Discard Changes

DISCARD [1] changes button will appear only when bank on the upper edit window has edits in it. This button will appear automatically, indicating that edit mode is “active”. You can discard any changes made to the bank if you are not happy with your bank edits.

VirusHC User Manual - Discard Changes

Virus Editor User Manual – Discard Changes

NOTE #1 when button is visible, bank selection menu for the upper data view is not accessible unless you save your changes or discard your edits.

Browse Patches by Category

User can browse single Patches when Category Filter [1] is toggled on.  After that, user can select the category they want to browse for.

VirusHC User Manual - Category Filter

Virus Editor User Manual – Category Filter

When category [1] is chosen, lower patch view will show results [3] for the selected category. There can be several “banks” worth of category patches, which can be chosen from the bank select menu [2].

VirusHC User Manual - Category Browsing

Virus Editor User Manual – Category Browsing

Previously in Virus Editor​ User Manual

Main Functions

et|icon_book_alt|

Chapter 5 of 6

Next in Virus Editor User Manual

Librarian Edit menus

0
0
630
Rate this user guide

Spread the word with your community ❤️ Thank you!

0 Shares
Tweet
Share
Reddit
Share
Share